Содержание

Содержание (текущая страница)
Лицензионное соглашение
О программе (общая информация)
Общие сведения...
Список изменений...
Краткое описание (разделы)
Окно сканирования (основное окно)...
Окно теста (дополнительное окно)...
Окно поиска (дополнительное окно)...
Окно портов (дополнительное окно)...
Окно мониторинга (дополнительное окно)...
Окно статистики (дополнительное окно)...
Окно маршрутов (информационное окно)...
Контакты (связь с автором)


IPMScan

ЛИЦЕНЗИОННОЕ СОГЛАШЕНИЕ (Russian)

Тип лицензии: Freeware (Бесплатно)
Программа: IPMScan © VRCP Soft
Автор: Салтыков Дмитрий Александрович

Это программное обеспечение защищено национальными законами и международными соглашениями об авторском праве. Все исключительные права на использование этого программного обеспечения принадлежат её автору (разработчику, правообладателю).

Этим программным обеспечением и всеми его компонентами можно пользоваться бесплатно, без лицензионных отчислений и неограниченное время. Можно без разрешения автора свободно распространять и размещать его на страницах интернет-ресурсов и электронных носителях без извлечения выгоды.

Запрещено коммерческое распространение этого программного обеспечения. Запрещено продавать или использовать его для извлечения выгоды как по отдельности так и в составе любого архива или сборки. Запрещено дизассемблировать, а также вносить любые изменения в программный код файлов, входящих в состав этого программного обеспечения.

Это программное обеспечение поставляется по принципу "КАК ЕСТЬ". Никаких гарантий не прилагается и не предусматривается. Вы используете это программное обеспечение на свой страх и риск. Ни при каких обстоятельствах автор не будет отвечать ни за какие потери или искажения данных, любую упущенную выгоду, ущерб репутации либо другой побочный или косвенный вред, нанесённый в процессе использования или неправильного использования этого программного обеспечения.


Скриншот (общий вид):


Информация о продукте:
Название программы:
Версия:
Последняя редакция:
Тип программы: 		VRCP IPMScan
5.3.4.2012.0
18.05.2012/19:24:54:00
Сетевой сканер/тестер/монитор/вьювер/поисковик

- Утилита для настройки и тестирования IPv4-сетей, быстрого получения различной информации об узлах системы. Поможет определить сетевую безопасность выбранного узла или просто получить необходимые сведения о сети и её узлах. Включает в себя сканер сети (подсети), задаваемого диапазона, с целью выявления доступных рабочих IP-адресов (узлов) с быстрым определением их MAC-адресов, позволяет провести тестирование выбранного узла по известному IP-адресу, определить IP-адрес по известному MAC-адресу или NET-имени, вывести подробную информацию о ресурсах узла и некоторую другую дополнительную информацию, позволяет следить за соединениями и трафиком локального узла, проверить открытые порты выбранного узла. По результатам работы ведётся подробный LOG-журнал всех выполняемых действий.

Параметры, настройки и устранение неисправностей:

--------------------------------------------------------------------------------------------------------------------
При запуске программы с ключом (параметром):

"0" - информационные сообщения при загрузке программы выводятся на Русском языке
(как и при пустом или ошибочном параметре);
"1" - информационные сообщения при загрузке программы выводятся на Английском языке;
"2" - трансляция кодировки DOS/WIN путей и различных имён будет запрещена!
(может помочь на ОС с языком отличным от Русского и/или Английского).
--------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------
ВНИМАНИЕ !!!
Для правильной работы утилиты настоятельно рекомендуется отключать во время
её работы все установленные межсетевые экраны и средства антивирусной защиты!
Добавление в исключения только одного исполняемого файла IPMScan.exe
не гарантирует правильную работу утилиты!
--------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------
При проблеме запуска программы
в ОС Microsoft Windows NT/2000/XP/2003/Vista/2008/7/8/2012:
- вероятнее всего её нужно запустить с правами администратора или отключить UAC.

При проблеме запуска программы в ОС Microsoft Windows x64:
- не запускать программу из папки \Program Files (x86)\...

При проблеме запуска и работы программы
в ОС MS Windows 95/98/ME/NT:
- скопировать/заменить файл "oleaut32.dll " в папку(е) "ПУТЬ_К_WINDOWS/SYSTEM/ ";
- скопировать/заменить файл "psapi.dll " в папку(е) "ПУТЬ_К_WINDOWS/SYSTEM/ ";
- установить и настроить "himem.sys " и "emm386.exe ":
Пример ( config.sys ):
dos=high,umb
devicehigh=himem.sys
devicehigh=emm386.exe
stacks=0,0

Если программа не запускается в графическом режиме:
- установить масштабирование (DPI) экрана равным 96 (100%) или 120 (125%).

Также при каких либо сбоях работы программы:
- в каждой подпапке находятся файлы "StopAll.bat ", которыми можно полностью
выгрузить все компоненты программы из оперативной памяти;
- для нормальной работы программы возможно потребуется временно отключить
все фаерволы (брандмауэры) и антивирусную защиту.
--------------------------------------------------------------------------------------------------------------------

--------------------------------------------------------------------------------------------------------------------
Если планируется использовать программу только на определённой ОС,
то для уменьшения объёма, занимаемого программой, можно в папке
с программой оставить только одну из подпапок, относящейся к данной
операционной системе, а остальные удалить!

Оставить:
- для Windows 95
- для Windows 98
- для Windows ME
- для Windows NT
- для Windows 2000
- для Windows XP
- для Windows 2003
- для Windows Vista
- для Windows 2008
- для Windows 7
- для Windows 8
- для Windows 2012 		- подпапку "95 "
- подпапку "98 "
- подпапку "Me "
- подпапку "NT "
- подпапку "2k "
- подпапку "XP "
- подпапку "2k3 "
- подпапку "V7 "
- подпапку "V7 "
- подпапку "V7 "
- подпапку "V7 "
- подпапку "V7 "
--------------------------------------------------------------------------------------------------------------------


Отличия программы IPMScan версии 5.3.4.2012.0 от 5.3.3.2012.0:

  +  добавлена дополнительная база данных, содержащая имена сетевых портов;
  +  добавлена возможность распечатки лога на принтере непосредственно из программы;
  +  добавлена поддержка работы утилиты в OS Microsoft Windows 8/2012 Server;

  *  вывод в лог количества найденных узлов при циклическом сканировании IP-адресов;
  *  поиск IP-адреса узла по MAC-адресу в логе производится теперь не только для
      просканированного диапазона IP-адресов, но и для каждого протестированного узла;
  *  немного улучшен пользовательский интерфейс утилиты;
     (удобство заполнения полей IP/MAC-адресов, более подробные подсказки и описание,
      копирование строки из лога опцией всплывающего меню и др.)
  *  обновлена база данных, содержащая информацию о MAC-адресах;
  *  обновлены файлы помощи "IPMScanR.chm" и "IPMScanE.chm";
  *  немного подкорректирован файл дополнительной, загружаемой вручную, конфигурации;

  -  для корректной работы всех функциональных возможностей, заложенных в утилиту,
     исключён её запуск под учётной записью с ограниченными правами.

Отличия программы IPMScan версии 5.3.3.2012.0 от 5.3.2.2012.0:

  +  добавлено определение MAC-адресов для узлов, находящихся за маршрутизаторами,
      роутерами, а также находящихся в других подсетях;
  +  добавлено отображение в логе всех NetBIOS-имён удалённого тестируемого узла;
  +  поиск IP-адреса узла по MAC-адресу теперь производится ещё и в логе программы;
     (перед поиском необходимо просканировать необходимый диапазон IP-адресов)

  *  скорректировано определение значения SID для локальных IP-адресов;
  *  немного улучшены алгоритмы определения операционной системы, рабочей группы
      и сетевого имени удалённого тестируемого узла;
  *  немного улучшены алгоритмы подсчёта статистических данных тестируемого узла;
  *  обновлена база производителей оборудования, определяемых по MAC-адресам;
  *  улучшена совместимость со старыми ОС Microsoft Windows NT4/Me/98/95.

Отличия программы IPMScan версии 5.3.2.2012.0 от 5.3.1.2012.0:

  +  список учётных записей с их паролями выведен в отдельный файл users.txt;
  +  добавлено определение внешнего IP-адреса при получении информации о системе;
  +  добавлено отображение в логе значения SID тестируемого узла;
  +  IP-адрес из окна лога копируется в окно теста по нажатию клавиши ENTER;

  *  исправлена невозможность сканирования нескольких подсетей в обратном порядке;
  *  немного расширена получаемая информация о локальной системе;
  *  улучшена стабильность работы программы в Windows Vista/2008/7;
  *  немного увеличена скорость работы программы.

Отличия программы IPMScan версии 5.3.1.2012.0 от 5.3.0.2011.0:

  +  добавлено определение фирмы производителя устройства по его MAC-адресу;
  +  добавлен вывод некоторой дополнительной общей информации о системе;
  +  добавлена возможность скопировать LOG из окна статистики сетевых соединений;
  +  добавлена возможность просмотра информации об узле через WhoIS по его NET-имени;

  *  исправлено отображение недоступного IP-адреса как локального в некоторых случаях;
  *  исправлен ошибочный подсчёт UDP-портов при повторном сканировании портов узла;
  *  исправлен не всегда правильный подсчёт найденных ресурсов на тестируемом узле;
  *  исправлены зависания программы в некоторых случаях при тестировании узла;
  *  немного улучшен интерфейс и работа некоторых функций программы.

Отличия программы IPMScan версии 5.3.0.2011.0 от 5.2.0.2010.0:

  +  добавлено отображение количества процессов/портов в окне мониторинга;
  +  добавлено отображение количества маршрутов и процессов в окне лога;
  +  добавлена кнопка для просмотра предыдущего LOG-файла;
  +  добавлено получение некоторой дополнительной расширенной информации о системе;

  *  скорректирована кодировка текста в окнах мониторинга процессов и маршрутов;
  *  немного улучшено сканирование открытых TCP/UDP портов;
  *  улучшена совместимость работы программы с ОС Microsoft Windows Vista/2008/7;
  *  улучшена совместимость работы программы с серией ОС Microsoft Windows x64;
  *  немного расширена информация записываемая в LOG;
  *  немного улучшены интерфейс и работа программы в целом;
  *  обновлены все файлы помощи до актуальных версий.

Отличия программы IPMScan версии 5.2.0.2010.0 от 5.1.0.2008.0:

  +  в окне теста добавлена функции открытия узла по ftps протоколу;
  +  в окне теста добавлена функция открытия узла как по IP-адресу так и по NET-имени;
  +  добавлено сохранение заметок в окне мониторинга в файл конфигурации;
  +  добавлен файл конфигурации для быстрого сканирования домашней локальной сети;

  *  интерфейс доработан для работы на мониторе с DPI=96/120 (точек на дюйм);
  *  немного расширена получаемая информация об узлах и системе;
  *  исправлены некоторые ошибки приводящие в некоторых случаях к подвисанию программы;
  *  немного увеличена скорость, улучшен интерфейс и работа программы в целом.

Отличия программы IPMScan версии 5.1.0.2008.0 от 5.0.0.2008.0:

  *  немного улучшен интерфейс и управление в программе;
  *  немного улучшена стабильность работы программы в целом в различных ОС;
  *  скорректировано отображение некоторой получаемой информации;
  *  поддерживается запуск и работа программы на ОС Microsoft Windows 7.

Отличия программы IPMScan версии 5.0.0.2008.0 от 4.6.0.2008.0:

  +  в окно мониторинга добавлена кнопка просмотра таблицы сетевых маршрутов;
  +  в окно теста добавлена функция поиска доступных портов узла;
  +  добавлено отображение информации о локальном IPX/SPX-протоколе;
  +  добавлено отображение локального хоста (127.0.0.1);

  *  немного улучшена работа программы в целом;
  *  по умолчанию в программе устанавливается русский язык интерфейса.

Отличия программы IPMScan версии 4.6.0.2008.0 от 4.5.0.2008.0:

  +  в окно теста добавлено определение описания, имён пользователей, группы и ОС узла;
  +  в окне теста добавлена кнопка "telnet" для быстрого TelNet-соединения с узлом;
  +  добавлены функции (кнопки) сохранения и загрузки текущей конфигурации;

  *  улучшена работа с русскими именами узлов сети;
  *  в окне теста объединены кнопки "http:" и "https:";
  *  немного улучшен интерфейс и работа программы;

  -  исправлено ограничение времени ожидания узла с 30 сек. до 60 сек.

Отличия программы IPMScan версии 4.5.0.2008.0 от 4.0.0.2008.0:

  +  добавлено окно статистики сетевых соединений для IPx, TCPx, UDPx, ICMPx протоколов;

  *  улучшен метод поиска ресурсов;
  *  более подробная информация о локальных сетевых настройках;
  *  повышена стабильность работы программы в NT-подверсиях ОС MS Windows;
  *  улучшен пользовательский интерфейс для ещё более удобного использования.

Отличия программы IPMScan версии 4.0.0.2008.0 от 3.0.0.2007.0:

  +  добавлено окно мониторинга TCPx/UDPx сетевых соединений (процессов/приложений);
  +  добавлена возможность закрытия любого сетевого процесса из окна мониторинга;
  +  в окне теста добавлена кнопка "https:" для быстрого открытия подобных страниц;
  +  добавлена анимационная иконка в трее для более удобного просмотра текущих действий;
  +  добавлена поддержка OS MS Windows 2008 Server;
  +  добавлен вывод в LOG значений IP-адресов и масок в HEX и BIN форматах;
  +  добавлена возможность просмотра скрытых ресурсов узла;
  +  добавлен возможность сканирования адресов в обратном порядке;
  +  добавлена поддержка работы на компьютерах с установленным IPv6-протоколом;
  +  добавлен(ы) файл(ы) помощи "IPMScanR.chm " ( "IPMScanE.chm ");

  *  немного изменён (подправлен) интерфейс программы для более удобного использования;
  *  в некоторых местах программы немного увеличена скорость обработки данных;
  *  повышена стабильность работы программы в различных подверсиях ОС MS Windows;

  -  исправлен ряд ошибок, приводящих в некоторых случаях к неправильным результатам;
  -  исправлена некорректная работа с русскими именами узлов;
  -  исправлена проблема утечки памяти при долгой работе в OS MS Windows 95/98/ME.

Отличия программы IPMScan версии 3.0.0.2007.0 от 2.0.0.2007.0:

  +  добавлено окно поиска IP-адреса по MAC-адресу и NET-имени.

Отличия программы IPMScan версии 2.0.0.2007.0 от 1.0.0.2007.0:

  +  добавлено окно тестирования и просмотра информации об узле по IP-адресу.

( + добавление, * изменение, - исправление/удаление )


Стартовое окно:

- данное окно появляется после запуска файла "IPMScan.exe ", после чего необходимо дождаться появления надписи "Loading... OK!" и нажать на окне любой кнопкой мыши или клавиатуры для запуска программы!


Окно сканирования IP-адресов (главное):

- данное окно открывается после окна-заставки и является основным (главным) окном,
из которого осуществляется управление всеми остальными окнами программы;
- так же это окно является сканером диапазона IP-адресов (под)сети(ей);
- в этом окне отображается подробный ЛОГ всех проводимых программой операций.

 1 - запуск процесса сканирования выбранного (в 22 и 23) диапазона IP-адресов
 2 - остановка процесса сканирования IP-адресов
 3 - выход из программы с остановкой всех выполняемых процессов
 4 - сохранение всего текста ЛОГ'а в файл
 5 - копирование всего текста ЛОГ'а в буфер обмена ОС
 6 - копирование выбранной строки ЛОГ'а в буфер обмена ОС
 7 - полная очистка окна ЛОГ'а
 8 - краткая информация о программе
 9 - информация о системе и локальном сетевом окружении
 10 - открыть окно мониторинга сетевых процессов (соединений)
 11 - открыть окно тестирования узла
 12 - выбор языка интерфейса (русский или английский)
 13 - текущая дата
 14 - текущее время
 15 - текстовое поле добавления строки комментария в ЛОГ
 16 - добавление строки комментария в ЛОГ
 17 - подробный ЛОГ о всех выполняемых программой операциях
 18 - вызов справки к программе (опция "Help...")
 19 - шкала-индикатор выполняемого процесса
 20 - индикатор завершения выполняемого процесса в процентах
 21 - меню работы с выбранной строкой ЛОГ'а (клик мышью)
 22 - начальный IP-адрес сканирования
 23 - конечный IP-адрес сканирования
 24 - количество запросов узла
 25 - TTL (время жизни посылаемого пакета запроса)
 26 - размер пакета запроса (в байтах)
 27 - время ожидания ответа на запрос
 28 - циклический повтор сканирования выбранного диапазона адресов
 29 - вкл./выкл. автоматического определения количества запросов узла
 30 - вкл./выкл. автоматического определения TTL пакета запроса
 31 - вкл./выкл. автоматического определения размера посылаемого пакета запроса
 32 - вкл./выкл. автоматического определения времени ожидания ответа на запрос
 33 - свернуть окно сканирования
 34 - выход из программы с остановкой всех выполняемых процессов
 35 - загрузить сохранённую конфигурацию (настройки)
 36 - сохранить текущую конфигурацию (настройки)
 37 - просмотр ранее созданного (предыдущего) ЛОГ'а


Окно теста адреса (и просмотра ресурсов):

- данное окно открывается нажатием кнопки "T. " в главном окне программы;
- в этом окне отображается дополнительная информация о конкретном
выбранном узле, заданным IP-адресом, и некоторые функции для проверки
работоспособности и доступности служб узла.

 1 - запуск процесса тестирования выбранного узла (по IP-адресу)
 2 - остановка процесса тестирования узла
 3 - скрыть окно тестирования узла (с остановкой выполняемого тестирования)
 4 - открыть узел по IP-адресу или NET-имени как папку
 5 - открыть узел по IP-адресу или NET-имени как http/https-страницу
 6 - открыть узел по IP-адресу или NET-имени как ftp/ftps-архив
 7 - установить с узлом telnet-соединение по IP-адресу или NET-имени
 8 - отправка тестового сообщения на узел
 9 - открыть подробную информацию об узле (сервис WhoIS через InterNet)
 10 - открыть окно поиска IP-адреса по MAC-адресу или NET-имени
 11 - IP-адрес тестируемого узла
 12 - количество запросов узла
 13 - TTL (время жизни посылаемого пакета запроса)
 14 - размер пакета запроса (в байтах)
 15 - время ожидания ответа на запрос
 16 - вкл./выкл. автоматического определения количества запросов узла
 17 - вкл./выкл. автоматического определения TTL пакета запроса
 18 - вкл./выкл. автоматического определения размера посылаемого пакета запроса
 19 - вкл./выкл. автоматического определения времени ожидания ответа на запрос
 20 - текстовое поле ввода тестового сообщения для отправки на узел
 21 - шкала-индикатор выполняемого процесса
 22 - индикатор завершения выполняемого процесса в процентах
 23 - MAC-адрес узла
 24 - NET-имя узла
 25 - описание узла
 26 - имя пользователя(ей) узла
 27 - группа (домен) в которую входит узел
 28 - операционная система (ОС) установленная на узле
 29 - сетевые ресурсы узла
 30 - среднее время (задержка) доступа к узлу
 31 - среднее время жизни (TTL) пакета до узла
 32 - процент успешных запросов узла
 33 - количество успешных запросов узла
 34 - процент ошибок запроса узла
 35 - количество ошибочных (без ответа) запросов узла
 36 - открыть окно сканирования доступных портов узла
 37 - скрыть окно тестирования (с остановкой всех выполняемых процессов)


Окно поиска IP-адреса:

- данное окно открывается нажатием кнопки "IP" в окне теста;
- в этом окне выбирается метод поиска узла (его IP-адреса), а так же производится поиск,
с выводом найденного IP-адреса в окно теста (по окончанию работы скрывается).

 1 - запуск процесса поиска IP-адреса (по MAC-адресу или NET-имени)
 2 - остановка (отмена) поиска IP-адреса и скрытие окна поиска
 3 - выбор параметра поиска IP-адреса (по NET-имени или MAC-адресу)
 4 - текстовое поле ввода NET-имени для поиска
 5 - поле ввода MAC-адреса (48-битного) для поиска
 6 - скрыть окно поиска (с остановкой всех выполняемых процессов)


Окно сканирования портов:

- данное окно открывается нажатием кнопки "Порты" в окне теста;
- в этом окне отображаются найденные доступные порты тестируемого узла.

 1 - запуск процесса сканирования (поиска) доступных портов узла (по IP-адресу)
 2 - прерывание (отмена) сканирования (поиска) доступных портов узла
 3 - текстовое поле отображающее IP-адрес сканируемого узла
 4 - текстовое поле выбора скорости (задержки) сканирования портов
 5 - текстовое поле ввода начального номера порта для сканирования
 6 - текстовое поле ввода конечного номера порта для сканирования
 7 - выбор постоянной (выбранной в поле 4) или переменной скорости сканирования портов
 8 - выбор последовательной или случайной выборки номеров сканируемых портов
 9 - шкала-индикатор выполняемого процесса
 10 - номер текущего сканируемого порта, а так же информация о выполняемом процессе
 11 - список найденных доступных портов проверяемого узла (указанного в поле 3)
 12 - скрыть окно сканирования портов узла (с остановкой всех выполняемых процессов)


Окно мониторинга сетевой активности (процессов):

- данное окно открывается нажатием кнопки "M." в главном окне программы;
- в этом окне производится мониторинг сетевых соединений (процессов/приложений).

 1 - запуск процесса мониторинга сетевой активности (процессов) по протоколам TCPx/UDPx
 2 - остановка (пауза) процесса мониторинга сетевой активности (процессов)
 3 - копирование текущего ЛОГ'а сетевой активности (списка процессов) в буфер обмена ОС
 4 - копирование выбранного IP-адреса из ЛОГ'а в окно тестирования узла
 5 - обновление вручную ЛОГ'а сетевой активности (списка процессов)
 6 - удаление (остановка) выбранного из ЛОГ'а процесса (приложения)
 7 - открыть окно статистики сетевых соединений по протоколам IPx/TCPx/UDPx/ICMPx
 8 - открыть окно просмотра таблицы сетевых маршрутов
 9 - скрыть окно мониторинга (с остановкой всех выполняемых процессов)
 10 - вкл./выкл. форматирования всех адресов и портов ЛОГ'а
 11 - увеличение размера окна ЛОГ'а мониторинга на 1 строку
 12 - уменьшение размера окна ЛОГ'а мониторинга на 1 строку
 13 - вернуть исходный размер окна ЛОГ'а мониторинга
 14 - выбор вида вывода адресов и портов в ЛОГ (номеров или имён)
 15 - текстовое поле заметок
 16 - ЛОГ сетевой активности (список процессов) по протоколам TCPx/UDPx
 17 - меню для работы с выбранной из ЛОГ'а строкой (клик мыши)
 18 - закрыть окно мониторинга (с остановкой всех выполняемых процессов)


Окно статистики сетевых соединений:

- данное окно открывается из окна мониторинга сетевой активности;
- в этом окне отображается статистика сетевых соединений по протоколам
IPv4, IPv6, TCPv4, TCPv6, UDPv4, UDPv6, ICMPv4, ICMPv6.

 1 - обновление вручную ЛОГ'а статистики сетевых соединений
 2 - скрыть окно статистики (с остановкой всех выполняемых процессов)
 3 - вкл./выкл. автоматического обновления ЛОГ'а статистики сетевых соединений
 4 - период обновления ЛОГ'а статистики сетевых соединений (от 100 мс до 1000 мс)
 5 - увеличение скорости обновления ЛОГ'а статистики сетевых соединений на 100 мс
 6 - уменьшение скорости обновления ЛОГ'а статистики сетевых соединений на 100 мс
 7 - выбор вкладки ЛОГ'а статистики (протоколы: IPv4, IPv6, TCPv4, TCPv6, UDPv4, UDPv6, ICMPv4, ICMPv6)
 8 - закрыть окно статистики (с остановкой всех выполняемых процессов)


Окно таблицы сетевых маршрутов:

- данное окно открывается из окна мониторинга сетевой активности;
- в этом окне отображаются все текущие локальные сетевые маршруты.

 1 - таблица отображающая локальные сетевые маршруты
 2 - меню для работы с выбранной из таблицы строкой (клик мыши)
 3 - закрыть окно с таблицей сетевых маршрутов


Организация:
Автор:
 Псевдоним:
Домашняя WEB-страница:
Домашняя WAP-страница:
Форум:
Почтовый адрес E-Mail:
Номер ICQ:
Skype:
Расположение:
 VRCP Soft
Салтыков Дмитрий Александрович
ZXDemon
http://vrcp.ru/index.htm
http://vrcp.ru/index.wml
http://forum.vrcp.ru
vrcpsoft@gmail.com, admin@vrcp.ru
151234242
ZXDemon
г. Москва (Россия)